// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"@(?:import|plugin)\s+["']([^"']+)["']"#).unwrap();
let string = "@import \"tailwindcss\";
@plugin \"@tailwindcss/typography\";
@plugin \"daisyui\";
@plugin \"@iconify/tailwind4\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}