import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "for (?<user>[a-zA-Z\\.]+).*?(?<ip>(?:\\d{1,3}\\.){3}\\d{1,3})";
final String string = "Failed password for root from 123.183.209.132 port 39706 ssh2\n"
+ "Failed password for invalid user packer from 13.82.211.217 port 45832 ssh2\n"
+ "reverse mapping checking getaddrinfo for undefined.datagroup.ua [93.183.207.5] failed - POSSIBLE BREAK-IN ATTEMPT!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}