$re = '/for (?<user>[a-zA-Z\.]+).*?(?<ip>(?:\d{1,3}\.){3}\d{1,3})/m';
$str = 'Failed password for root from 123.183.209.132 port 39706 ssh2
Failed password for invalid user packer from 13.82.211.217 port 45832 ssh2
reverse mapping checking getaddrinfo for undefined.datagroup.ua [93.183.207.5] failed - POSSIBLE BREAK-IN ATTEMPT!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);