package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\bNOT\s+)?\w+) IN \('([^()]*)'\)`)
var str = `DEVICE_SIZE IN ('036','048','060','070') AND DEVICE_VOLTAGE IN ('1','3') AND NOT DEVICE_DISCHARGE_AIR IN ('S') AND NOT DEVICE_REFRIGERANT_CIRCUIT IN ('H','C')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}