$re = '/((?:\bNOT\s+)?\w+) IN \(\'([^()]*)\'\)/m';
$str = 'DEVICE_SIZE IN (\'036\',\'048\',\'060\',\'070\') AND DEVICE_VOLTAGE IN (\'1\',\'3\') AND NOT DEVICE_DISCHARGE_AIR IN (\'S\') AND NOT DEVICE_REFRIGERANT_CIRCUIT IN (\'H\',\'C\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);