package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^0{4}aw$`)
var str = `0000aW
0000aw
0000AW
0000Aw
0000aW3
Bb12345
BB09876
bB45668
bb45678
SA33445
bb123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}