const regex = /^0{4}aw$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0{4}aw$', 'igm')
const str = `0000aW
0000aw
0000AW
0000Aw
0000aW3
Bb12345
BB09876
bB45668
bb45678
SA33445
bb123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}