package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#\/(?:[A-Za-z]+(?:\/[A-Za-z]+)*)?$`)
var str = `#/
#/word/word
#/word
#/word/word/word`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}