import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^.*SIM ICC Id .*:*\\w+(\\w{6}.*)$";
final String string = "1,\"Ready information for interface Mobile Broadband Connection: \n"
+ "-------------------------------------\n"
+ " State : Ready to power up and register\n"
+ " Emergency mode : Off\n"
+ " Subscriber Id : 123450026373881\n"
+ " SIM ICC Id : 00000000000000124610\n"
+ " Number of telephone numbers : 1\n\n\n"
+ "2,\"Ready information for interface Mobile Broadband Connection: \n"
+ "-------------------------------------\n"
+ " State : Ready to power up and register\n"
+ " Emergency mode : Off\n"
+ " Subscriber Id : 123450026373881\n"
+ " SIM ICC Id : longer0000000000012342xxx10\n"
+ " Number of telephone numbers : 1\n\n"
+ "3,\"Ready information for interface Mobile Broadband Connection: \n"
+ "-------------------------------------\n"
+ " State : Ready to power up and register\n"
+ " Emergency mode : Off\n"
+ " Subscriber Id : 123450026373881\n"
+ " SIM ICC Id : shorter00012342xxx10\n"
+ " Number of telephone numbers : 1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}