const regex = /(?m)^.*SIM ICC Id .*:*\w+(\w{6}.*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^.*SIM ICC Id .*:*\\w+(\\w{6}.*)$', 'g')
const str = `1,"Ready information for interface Mobile Broadband Connection:
-------------------------------------
State : Ready to power up and register
Emergency mode : Off
Subscriber Id : 123450026373881
SIM ICC Id : 00000000000000124610
Number of telephone numbers : 1
2,"Ready information for interface Mobile Broadband Connection:
-------------------------------------
State : Ready to power up and register
Emergency mode : Off
Subscriber Id : 123450026373881
SIM ICC Id : longer0000000000012342xxx10
Number of telephone numbers : 1
3,"Ready information for interface Mobile Broadband Connection:
-------------------------------------
State : Ready to power up and register
Emergency mode : Off
Subscriber Id : 123450026373881
SIM ICC Id : shorter00012342xxx10
Number of telephone numbers : 1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}