package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[A-Z]|_[A-Z])([A-Za-z]+)`)
var str = `HELLO_WORLD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}