$re = '/(^[A-Z]|_[A-Z])([A-Za-z]+)/m';
$str = 'HELLO_WORLD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);