package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-z0-9]*_[A-z0-9]*[^_]*$`)
var str = `[]^\\`1_2_3_4_5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}