$re = '~^[A-z0-9]*_[A-z0-9]*[^_]*$~m';
$str = '[]^\\`1_2_3_4_5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);