import re
regex = re.compile(r"chip=\"(?<value>[^\"]+)|chip_name=\"(?<text>[^\"]+)")
test_str = ("node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_0\",chip_name=\"enp216s0f0np0\"} 1\n"
"node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_1\",chip_name=\"enp216s0f0np1\"} 1\n"
"node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_2\",chip_name=\"enp216s0f0np2\"} 1\n"
"node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_3\",chip_name=\"enp216s0f0np3\"} 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")