const regex = /^#\s([A-Za-z0-9]+( [A-Za-z0-9]+)+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#\\s([A-Za-z0-9]+( [A-Za-z0-9]+)+)$', 'gm')
const str = `# August 2024 News And Updates`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}