re = /^#\s([A-Za-z0-9]+( [A-Za-z0-9]+)+)$/m
str = '# August 2024 News And Updates'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end