# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(.{10}).*$
"""
test_str = ("Mary had a little lamb,\n"
"little lamb, little lamb.\n"
"Mary had a little lamb, its fleece was white as snow.\n"
"And everywhere that Mary went,\n"
"Mary went, Mary went,\n"
"and everywhere that Mary went, the lamb was sure to go.")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.