re = /^(.{10}).*$/xm
str = 'Mary had a little lamb,
little lamb, little lamb.
Mary had a little lamb, its fleece was white as snow.
And everywhere that Mary went,
Mary went, Mary went,
and everywhere that Mary went, the lamb was sure to go.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result