#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{3,4}(?:\s+)?х(?:\s+)?[0-9]{3,4}"
Local $sString = "237 000" & @CRLF & _
"1280х720" & @CRLF & _
"1280х720 (х кириллица)" & @CRLF & _
"1280 х 720" & @CRLF & _
"1280 х 720 (х кириллица)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")