re = /^[0-9]{3,4}(?:\s+)?х(?:\s+)?[0-9]{3,4}/m
str = '237 000
1280х720
1280х720 (х кириллица)
1280 х 720
1280 х 720 (х кириллица)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end