package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^ -~]`)
var str = `отправка.py
bla.py
bla23.py
bla23_.py`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}