$re = '/[^ -~]/';
$str = 'отправка.py
bla.py
bla23.py
bla23_.py';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);