$re = '/{{(?=(?:[^"\'{}]|"[^"]*"|\'[^\']*\')*?\bthis\b(?:[^"\'{}]|"[^"]*"|\'[^\']*\')*?\}\})(?:[^"\'{}]|"[^"]*"|\'[^\']*\')*?\bthis\b(?:[^"\'{}]|"[^"]*"|\'[^\']*\')*?}}/m';
$str = '{{this}}
{{ this.thing}}
{{
this
}}
{{concat "}}" this }}
{{concat "}}" "this" }}
{"this"}}
{{\'this\'}}
{{(this)}}
// fine
<Foo @foo=this />
<div {{this}}></div>
<Foo @foo={{this}} />
// not fine
<this.hello />
<s x={{if (foo hi=(two this))}}></s>
<Foo as |this|>
{{this}}
</Foo>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);