import re
regex = re.compile(r"{{(?=(?:[^\"'{}]|\"[^\"]*\"|'[^']*')*?\bthis\b(?:[^\"'{}]|\"[^\"]*\"|'[^']*')*?\}\})(?:[^\"'{}]|\"[^\"]*\"|'[^']*')*?\bthis\b(?:[^\"'{}]|\"[^\"]*\"|'[^']*')*?}}", flags=re.MULTILINE)
test_str = ("{{this}}\n"
"{{ this.thing}}\n"
"{{\n"
" this\n\n\n"
"}}\n"
"{{concat \"}}\" this }}\n"
"{{concat \"}}\" \"this\" }}\n"
"{\"this\"}}\n"
"{{'this'}}\n"
"{{(this)}}\n\n"
"// fine\n"
"<Foo @foo=this />\n"
"<div {{this}}></div>\n"
"<Foo @foo={{this}} />\n\n"
"// not fine\n"
"<this.hello />\n"
"<s x={{if (foo hi=(two this))}}></s>\n"
"<Foo as |this|>\n"
" {{this}}\n"
"</Foo>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")