#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\{\{(?:[^{}"]|"[^"]*"|'[^']*')*?(?<!['"'])\bthis\b(?!['"'])(?:[^{}"]|"[^"]*"|'[^']*')*?\}\})|(?:<(?:[^<>"']|"[^"]*"|'[^']*')*?(?<!['"'])\bthis\b(?!['"'])(?:[^<>"']|"[^"]*"|'[^']*')*?\/?>)|(?:<this\.[\w-]+(?:\s[^>]*)?\/?>)|(?:<[^<>\s]+(?:\s[^<>]*?)?\|\s*this\s*\|[^<>]*>)"
Local $sString = "{{this}}" & @CRLF & _
"{{ this.thing}}" & @CRLF & _
"{{" & @CRLF & _
" this" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"}}" & @CRLF & _
"{{concat "}}" this }}" & @CRLF & _
"{{concat "}}" "this" }}" & @CRLF & _
"{{"this"}}" & @CRLF & _
"{{'this'}}" & @CRLF & _
"{{(this)}}" & @CRLF & _
"" & @CRLF & _
"// fine" & @CRLF & _
"<Foo @foo=this />" & @CRLF & _
"<div {{this}}></div>" & @CRLF & _
"<Foo @foo={{this}} />" & @CRLF & _
"<s x={{if (foo hi=(two this))}}></s>" & @CRLF & _
"<this.hello />" & @CRLF & _
"<Foo as |this|>" & @CRLF & _
" {{this}}" & @CRLF & _
"</Foo>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")