import Foundation
let pattern = #"(?:\{\{(?:[^{}"]|"[^"]*"|'[^']*')*?(?<!['"'])\bthis\b(?!['"'])(?:[^{}"]|"[^"]*"|'[^']*')*?\}\})|(?:<(?:[^<>"']|"[^"]*"|'[^']*')*?(?<!['"'])\bthis\b(?!['"'])(?:[^<>"']|"[^"]*"|'[^']*')*?\/?>)|(?:<this\.[\w-]+(?:\s[^>]*)?\/?>)|(?:<[^<>\s]+(?:\s[^<>]*?)?\|\s*this\s*\|[^<>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{{this}}
{{ this.thing}}
{{
this
}}
{{concat "}}" this }}
{{concat "}}" "this" }}
{{"this"}}
{{'this'}}
{{(this)}}
// fine
<Foo @foo=this />
<div {{this}}></div>
<Foo @foo={{this}} />
<s x={{if (foo hi=(two this))}}></s>
<this.hello />
<Foo as |this|>
{{this}}
</Foo>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)