import Foundation
let pattern = #"^ {0,3}[\-][ \t]*[\-][ \t]*[\-][\- \t]*$|^ {0,3}[\*][ \t]*[\*][ \t]*[\*][\* \t]*$|^ {0,3}[_][ \t]*[_][ \t]*[_][_ \t]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - abc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)