import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!\\bfruit\\b).)* # nothing with \"fruit\" before\n"
+ "( # then, either:\n"
+ "# 1. fruit apple, followed by things that are not \"fruit\", followed by fruit banana, non-fruits, and then fruit cherry, or vice versa\n"
+ "\\bfruit\\b\\ apple((?!\\bfruit\\b).)*(\\bfruit\\b\\ banana((?!\\bfruit\\b).)*fruit\\ cherry|fruit\\ cherry((?!\\bfruit\\b).)*fruit\\ banana)\n"
+ "|\n"
+ "# 2. Same with banana at the beginning\n"
+ "fruit\\ banana((?!\\\\bfruit\\b).)*(fruit\\ apple((?!\\bfruit\\b).)*fruit\\ cherry|fruit\\ cherry((?!\\bfruit\\b).)*fruit\\ apple)\n"
+ "|\n"
+ "# 3. And with cherry\n"
+ "fruit\\ cherry((?!\\bfruit\\b).)*(fruit\\ apple((?!\\bfruit\\b).)*fruit\\ banana|fruit\\ banana((?!\\bfruit\\b).)*fruit\\ apple)\n"
+ ")\n"
+ "((?!\\bfruit\\b).)*$ # no more fruit";
final String string = "fruit apple \n"
+ "some other config line\n"
+ "############\n"
+ "fruit banana\n\n"
+ "fruit cherry\n"
+ "other config 1\n\n"
+ "other config";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}