const regex = new RegExp('^((?!\\bfruit\\b).)* # nothing with "fruit" before
( # then, either:
# 1. fruit apple, followed by things that are not "fruit", followed by fruit banana, non-fruits, and then fruit cherry, or vice versa
\\bfruit\\b\\ apple((?!\\bfruit\\b).)*(\\bfruit\\b\\ banana((?!\\bfruit\\b).)*fruit\\ cherry|fruit\\ cherry((?!\\bfruit\\b).)*fruit\\ banana)
|
# 2. Same with banana at the beginning
fruit\\ banana((?!\\\\bfruit\\b).)*(fruit\\ apple((?!\\bfruit\\b).)*fruit\\ cherry|fruit\\ cherry((?!\\bfruit\\b).)*fruit\\ apple)
|
# 3. And with cherry
fruit\\ cherry((?!\\bfruit\\b).)*(fruit\\ apple((?!\\bfruit\\b).)*fruit\\ banana|fruit\\ banana((?!\\bfruit\\b).)*fruit\\ apple)
)
((?!\\bfruit\\b).)*$ # no more fruit', 'gs')
const str = `fruit apple
some other config line
############
fruit banana
fruit cherry
other config 1
other config`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}