import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:\\\\\"|[^\"])*\"";
final String string = "And then, \"this is some sample text with quotes and \\\"escaped quotes\\\" inside\". Not that we need more, but... \"here is \\\"another\\\" one\". Just in case.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}