#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)string_value:(?=(?:(?!attributes_cache).)*name: last_name)\s+\"(\w+)\".*?attributes_cache"
Local $sString = "\- !ruby/object:DynamicAttribute " & @CRLF & _
" attributes: " & @CRLF & _
" resource_id: "1"" & @CRLF & _
" resource_type: Applicant" & @CRLF & _
" string_value: "Johnson1"" & @CRLF & _
" int_value: " & @CRLF & _
" id: "35533149"" & @CRLF & _
" date_value: " & @CRLF & _
" name: last_name" & @CRLF & _
" attributes_cache: {}" & @CRLF & _
"" & @CRLF & _
"\- !ruby/object:DynamicAttribute " & @CRLF & _
" attributes: " & @CRLF & _
" resource_id: "1"" & @CRLF & _
" resource_type: Applicant" & @CRLF & _
" string_value: "Michael"" & @CRLF & _
" int_value: " & @CRLF & _
" id: "35972390"" & @CRLF & _
" date_value: " & @CRLF & _
" name: first_name" & @CRLF & _
" attributes_cache: {}" & @CRLF & _
"" & @CRLF & _
"\- !ruby/object:DynamicAttribute " & @CRLF & _
" attributes: " & @CRLF & _
" resource_id: "1"" & @CRLF & _
" resource_type: Applicant" & @CRLF & _
" string_value: "Johnson2"" & @CRLF & _
" int_value: " & @CRLF & _
" id: "35533149"" & @CRLF & _
" date_value: " & @CRLF & _
" name: last_name" & @CRLF & _
" attributes_cache: {}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")