import re
regex = re.compile(r"^(\[(WIP|Draft)\]|(WIP|Draft))(:|\s)?", flags=re.MULTILINE)
test_str = ("[WIP]: lulz\n"
"[Draft]: hahaha\n"
"[Draft] lalalala\n"
"WIP: blah\n"
"WIP m000\n"
"Draft: foo\n"
" Draft: nope\n"
" WIP: more nope\n"
"WIP yeeeep\n"
"WIP:ahoy\n"
"WIP: ahoy matey!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")