package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{5,15}$`)
var str = `12345678910
1234567891`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}