$re = '/^[0-9]{5,15}$/m';
$str = '12345678910
1234567891';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);