#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+?(?=[^\S\n]{2,})"
Local $sString = "Some information on multiple line (6)" & @CRLF & _
"that I don't need and can't paste because" & @CRLF & _
"it contains some personal information. " & @CRLF & _
"So imagine a lot of text here..." & @CRLF & _
"So imagine a lot of text here..." & @CRLF & _
"So imagine a lot of text here..." & @CRLF & _
"" & @CRLF & _
"Sold To Bill To" & @CRLF & _
"Some Cie Some Other Cie" & @CRLF & _
"1111 chemin some-road 2222 chemin some-other-road" & @CRLF & _
"City-Here QC J0Q 1W0 Other City-Here QC J0Q 1W0 " & @CRLF & _
"Canada Canada"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")