import re
regex = re.compile(r"^.+?(?=[^\S\n]{2,})", flags=re.MULTILINE)
test_str = ("Some information on multiple line (6)\n"
"that I don't need and can't paste because\n"
"it contains some personal information. \n"
"So imagine a lot of text here...\n"
"So imagine a lot of text here...\n"
"So imagine a lot of text here...\n\n"
"Sold To Bill To\n"
"Some Cie Some Other Cie\n"
"1111 chemin some-road 2222 chemin some-other-road\n"
"City-Here QC J0Q 1W0 Other City-Here QC J0Q 1W0 \n"
"Canada Canada")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")