#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\/11F372288FA\/)(?:\/[^\/]+)+$"
Local $sString = "/software/11F372288FA/pagename" & @CRLF & _
"/software/13F412C5FA/pagename/summary" & @CRLF & _
"/software/XIL1P0BFXCKM81/pagename2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")