const regex = /^(?!.*\/11F372288FA\/)(?:\/[^\/]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\\/11F372288FA\\\/)(?:\\\/[^\\\/]+)+$', 'gm')
const str = `/software/11F372288FA/pagename
/software/13F412C5FA/pagename/summary
/software/XIL1P0BFXCKM81/pagename2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}