import Foundation
let pattern = #"(?<=(in:))[a-x0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"BLOCKSMKNETS forward: in:ether6 - Local TORF out:VLAN55 RT_INET, src-mac 5c:9a:d8:65:99:b7, proto TCP (SYN), 192.168.0.141:62632->192.168.6.18:65535, len 52"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)