package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(,\d+)?`)
var str = `233,2324
243d2324
234.2423
12331,22
12331,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}