$re = '/\d+(,\d+)?/';
$str = '233,2324
243d2324
234.2423
12331,22
12331,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);