#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m) (T.+?\.) (.+?\.)"
Local $sString = "This is a sentence. This is the sentence to be moved. And this is another sentence."
Local $sSubst = "$2 $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)