$re = '/ (T.+?\.) (.+?\.)/m';
$str = 'This is a sentence. This is the sentence to be moved. And this is another sentence.';
$subst = "$2 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;