#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\w*.?:\/\/)?\w*.?\w*\-?.?\w*\/(?:embed|e|v|watch|.*\/)?\??(?:feature=\w*\.?\w*)?\&?(?:v=)?\/?)([\w\d_-]+).*"
Local $sString = "http://www.youtube.com/watch?v=u8nQa1cJyX8&a=GxdCwVVULXctT2lYDEPllDR0LRTutYfW " & @CRLF & _
"http://www.youtube.com/watch?v=u8nQa1cJyX-8 " & @CRLF & _
"http://youtu.be/0zM3nApSvMg" & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/KdwsulMb8EQ " & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/embed/dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/e/dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/?v=dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ " & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/u/11/KdwsulMb8EQ " & @CRLF & _
"http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0" & @CRLF & _
"https://m.youtube.com/watch?feature=youtu.be&v=ROkXM3csNWY" & @CRLF & _
"https://www.youtube.com/watch?v=rie69P0W668" & @CRLF & _
"https://m.youtube.com/watch?feature=youtu.be&v=JqyzwbpYYqc" & @CRLF & _
"https://www.youtube.com/watch?v=YPln3JP_gKs&feature=youtu.be" & @CRLF & _
"https://www.youtube.com/watch?v=l-kX8Z4u0Kw&list=PLhml-dmiPOedRDLV8n1ro_OTdzKjOdlyp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")