import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\w*.?:\\/\\/)?\\w*.?\\w*\\-?.?\\w*\\/(?:embed|e|v|watch|.*\\/)?\\??(?:feature=\\w*\\.?\\w*)?\\&?(?:v=)?\\/?)([\\w\\d_-]+).*";
final String string = "http://www.youtube.com/watch?v=u8nQa1cJyX8&a=GxdCwVVULXctT2lYDEPllDR0LRTutYfW \n"
+ "http://www.youtube.com/watch?v=u8nQa1cJyX-8 \n"
+ "http://youtu.be/0zM3nApSvMg\n"
+ "http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/KdwsulMb8EQ \n"
+ "http://youtu.be/dQw4w9WgXcQ \n"
+ "http://www.youtube.com/embed/dQw4w9WgXcQ \n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ \n"
+ "http://www.youtube.com/e/dQw4w9WgXcQ \n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ \n"
+ "http://www.youtube.com/?v=dQw4w9WgXcQ \n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ \n"
+ "http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ \n"
+ "http://www.youtube.com/user/IngridMichaelsonVEVO#p/u/11/KdwsulMb8EQ \n"
+ "http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0\n"
+ "https://m.youtube.com/watch?feature=youtu.be&v=ROkXM3csNWY\n"
+ "https://www.youtube.com/watch?v=rie69P0W668\n"
+ "https://m.youtube.com/watch?feature=youtu.be&v=JqyzwbpYYqc\n"
+ "https://www.youtube.com/watch?v=YPln3JP_gKs&feature=youtu.be\n"
+ "https://www.youtube.com/watch?v=l-kX8Z4u0Kw&list=PLhml-dmiPOedRDLV8n1ro_OTdzKjOdlyp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}