using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_([0-9]*)";
string input = @"https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_1032027fd
https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_32027fd
https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_11032027fd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}