re = /_([0-9]*)/m
str = 'https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_1032027fd
https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_32027fd
https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_11032027fd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end