import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(?:\\.\\w+){0,}@sun-asterisk\\.com$";
final String string = "nguyen.quang.vinhb @sun-asterisk.com\n\n"
+ "nguyen.quang.vinhb.@sun-asterisk.com\n\n"
+ "nguyen.quang.vinhb@sun-asterisk.com111\n\n"
+ "nguyen.quang.vinhb@sun-asterisk.com\n\n"
+ "nguyen.quang..vinhb@sun-asterisk.com\n\n"
+ ".nguyen.quang.vinhb@sun-asterisk.com\n\n"
+ "nguyen@quang.vinhb@sun-asterisk.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}