$re = '/^\w+(?:\.\w+){0,}@sun-asterisk\.com$/m';
$str = 'nguyen.quang.vinhb @sun-asterisk.com
nguyen.quang.vinhb.@sun-asterisk.com
nguyen.quang.vinhb@sun-asterisk.com111
nguyen.quang.vinhb@sun-asterisk.com
nguyen.quang..vinhb@sun-asterisk.com
.nguyen.quang.vinhb@sun-asterisk.com
nguyen@quang.vinhb@sun-asterisk.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);